UEFI boot slow with Nitrokey Pro plugged in

As the title says, my UEFI takes an unusually long time to boot, when the Nitrokey Pro is plugged in. Normally I barely see the UEFI screen at all and now it takes like 10 seconds or so. It’s not that big of a deal but it’s still a bit inconvenient. I have no idea, if there’s nothing I can do about it (except for unplugging it, obviously, but I don’t want to plug and unplug it so much) or if there’s an option in the UEFI which is causing the problem.

My mainboard is a Gigabyte GA-H97-HD3 and firmware version F9c.
I’ll try an earlier version of the fw later.

Thanks in advance.

I suspect that your computer checks the USB devices for bootable drives. Try to disable booting from USB or at least decrease its priority (behind internal HDD/SDD).

I checked. The first and only thing I set the UEFI to boot from is my SSD. The Nitrokey is not even selectable and as said, everything besides the SSD already was disabled.

I discovered the same but with Nitrokey HSM on one of my Supermicro Servers. I rarely reboot so no real issue for me.

Well, for me it is an issue. :frowning:
I tried an earlier version of the UEFI, F7 but it was the same.

Is booting with Nitrokey Pro plugged in as fast as usual on other mainboards?

Hi Tschaeggaer,

at least for me it is not slowing down the boot (Thinkpad T430s). I think this is more a mainboard issue as they handle the hardware initialization different and it will be probably difficult for Nitrokey to handle/debug the different models etc.

What you could try is to look if there is a kind of hardware check enabled. Many mainboards let the user disable this kind of checks (sometimes referred to as “Quick Boot”). To be honest, this is all I can say for now :thinking:

Kind regards


thanks for the help so far. I tried every UEFI setting remotely related to my issue but it didn’t help. I already suspected that this is more of a problem with the mainboard than with the Nitrokey and that you can’t really do much about it. I really appreciate your help though. If I have news or a solution I will keep you up to date.

Thanks and regards

That would be kind! Thanks!
Hope you find something.

Here’s what Gigabyte support replied:

Daran werden wir nichts ändern könne, dies kommt vom USB Key PEN.

Was Sie probieren können ist folgendes:

Schalten Sie FAST Boot im Bios ein und dann bei USB Support Disabled.
Die USB Ports arbeiten dann erst im Windows.

Hat aber auch zur Folge, das Sie das Bios dann nur über PS Keyboard erreichen.

English (my own translation):

We won’t be able to change that, it’s originating from the USB Key PEN. You can try this:
Activate FAST Boot in the UEFI and Disable “USB Support”. USB Ports will only be available in Windows. But this will also lead to the UEFI only being accessible via PS/2 keyboard.

Meaning I probably won’t change it. Because I don’t have a PS/2 keyboard and I don’t want to “go” all the way to the mainboard battery to remove it just to access the UEFI which I do from time to time.
Thanks for all your help. :slight_smile:


thanks for your update!

Kind regards