Wifi not working anymore on Nitropad X230


ordered Nitropad - WIFI was working at the beginning - did some qube updates but not sure if it was a problem with that.

The WIFI-Key on F5 seems to has no function when running together with Fn+F5 ( other devices like volume are running)

when qubes has started, rightclick on network connections i find “enable wifi” with no hook in it, so it seems to be disabled.

What to do to get it enabled back on startup again?

1 Like

could get it back manually with

sudo rmmod iwldvm
sudo modprobe iwldvm

then wifi is hooked on again, but i´m not able to connect to any wifi either (Wi-Fi Networks tell me “device not ready”)

so what is about the hardware switch on Fn+F5 and where can i setup to use wifi again in Qubes after reboot directly ?

Hallo @QBert,

Did you restart the [sys-net] qube after entering the commands?

For further information on Qubes wireless debugging, they have a dedicated documentation available here.

If it does not help, please let me know, so we can see how to fix this issue.


Hi [nitr0z], thx for the fast reply which brings me a step further:

now i see new state for Wi-Fi Networks (left click on network connections) which tells me "Wi-Fi is disabled by hardware switch

Did you restart the [sys-net] qube after entering the commands? -->
After restarting cube, settings are like before (enable Wifi is unhooked and state is “Wi-Fi is disabled”

So that seems to be the problem on its root - how to activate WIFI again on its hardwareswitch
(with Fn+F5 (which seems to have no effect wheather to push before OS has loaded nor within loaded Qubes)

and yes - the hardwareswitch for WIFI on the left side of X230 is set to green (all the time), i have tried to switch off and on, but no reaction like pushing Fn+F5

I think its not a Qube-Problem at all, more hardware ?!

Hi @QBert!
Can you ask in parallel on QubesOS forum too? Perhaps this is some known problem.

Hallo again @QBert

I took a closer look at the wifi debugging page in the Qubes docs, and it seems that the issue is related to the wifi drivers, as they might seem to not persist after reboot.

Did you try the Qubes fix all the way through, or the two instructions only?

I would recommend to try the whole process described in the Qubes docs, and see if it works. If it does not work, please let us know. We will probably need to see the logs.

I posted a question at this link.

Hi guys,

first of all, thumbs up for the fast replies - tried different things and one of this fixed the problem.

Bad that i don´t know which solution helped, but i´m back to “business”.

Keep going, that shit rules ! :slight_smile:

1 Like


In case you would pinpoint this later to the exact solution please post it here for other users. Thank you!