Windows 10 does not recognize smartcard

My Notebook does not recognize the smart card of the nitrokey.

Ordinary smartcards are not problem (reader is included) but the smartcard on the nitrokey is simply not recognized by the system.
I have tried Kleopatra, GPA and Enigmail, none of the work.


What Nitrokey do you have?

Its a Nitrokey 2 Storage 16GB. I actually bought two of the for redundancy reaons, but the issue is the same with both of them.

I am using a Lenovo Thinkpad x250, with integradted smartcard reader. This is an “Alcor Micro USB Smart Card Reader” according to the system.

When I plug in the Nitrokey, it registers a smartcard reader, type “Microsoft usbccid-smartcard-leser (WUDF)”, and this works fine according to the system manager.

But no software that i use actually recognizes it. I have tried Kleopatra, Gnu Privacy Assistant, AloAha Smart Card Connector and GnuPG on the CLI. I have tried it with a SC in the fixed reader and without one in there, the results are always the same.

1 Like

Could you mention as well the Windows 10 version / build number?

What message do you get with GnuPG?
Perhaps the internal smart card reader takes the default place, and GnuPG is not searching further. Could you try again with it disabled (e.g. via BIOS/UEFI)?

The windows version ist 1803, Build 17134.885

I have tried the UEFI, but there is no option to turn of the device. I tried shutting it of in the hardware manager of windows (and rebooting), which worked, but the relevant software still did not recognize the reader on the nitrokey, even with the integrated reader shut down.

Regarding the error message: there is no error message per se, GnuPG simply states that there is no compatible smart card inserted.