[New User] "Nitrokey is Not Connected"

I recently purchased and received my Nitrokey Storage USB drive.

My operating system is Linux Mint. I read the installation documentation, I installed the libraries by typing “sudo apt-get update && sudo apt-get install libccid” into the CLI.

I downloaded the Linux Nitrokey AppImage and successfully wrote it as an executable file.

However, when I plug in my Nitrokey Storage USB, the app reads, “Nitrokey is not connected!”

The firmware is up to date. When I click on “About Nitrokey,” - it reads, “Nitrokey is not active.”

So, what steps am I missing?

I went on the YouTube channel and the video tutorial of the Nitrokey Storage overview does not show anything about connecting the device to the app. In the video, the app reads the user’s device and gives the user options that are not available to me since my app doesn’t connect to my device.

Furthermore, I am trying to copy highly sensitive documents from a standard USB to the Nitrokey USB.

It doesn’t allow me to copy these documents because it says the Nitrokey itself is “Read Only.” When I right click to change the permissions on the Nitrokey device itself, it doesn’t allow me to change the device to read, write access. Nor does it allow me to create and delete files.

Please help.


I am no LINUX specialist, but have you checked with something like ‘lsusb’ if the device is visible when connected ?
Also check if https://www.nitrokey.com/documentation/frequently-asked-questions-faq#latest-device-driver-missing-on-older-linux-distribution your libccid is new enough - maybe MINT has an old one and you need to add the Vendor and ProductID’s
For the Read-Only Trouble was another thread here on the forum.
Nitrokey Stuck in read-only only in Linux

1 Like


Most probably you do not have the proper Udev rules installed. The libccid package does contain some rules, but only for the smart card access, and not for the Nitrokey App.
Regular Ubuntu/Debian Nitrokey App package contains it, Snap and AppImage does not.

Please take a look at:

You can install the Udev rules with the following snippet:

wget https://raw.githubusercontent.com/Nitrokey/libnitrokey/master/data/41-nitrokey.rules
sudo mv 41-nitrokey.rules /etc/udev/rules.d/

Edit: This will not update the rules automatically in the future however. Since Mint is Ubuntu based, the Nitrokey’s PPA should work here as well - see https://www.nitrokey.com/download/ubuntu.

Edit: AFAIR Nitrokey Storage volume is indeed read-only by default. You need Nitrokey App to change that: Menu -> Configure -> Set unencrypted volume read-write.

Thank you!!!
I really appreciate it! The Ubuntu download instructions worked and now the app successfully recognizes and reads the device, but now there is another issue.

Although I successfully updated the user PIN and admin PIN through the app, when I hit the “Configure” option to set the unencrypted volume to read-write, it prompts me to enter the user pin.

When I enter the user pin, which I know without a shadow of a doubt is absolutely correct, a pop-up box tells me that it is the wrong PIN.

To be sure, I reset the pin on three separate occasions, and input the new (and correct) pins each and every time, but it tells me that is the wrong PIN, no matter what.

Any idea why that might be happening?

The nitrokey-app package has installed the Udev rules as well, which gives the access to the device.

However, for the Nitrokey Storage v0.54 the minimum Nitrokey App version is v1.4.
I believe you are using now older version, which is not handling the latest firmware communication protocol.
Please try again with the AppImage or Snap package (which are v1.4), either without removing the nitrokey-app system package (which is probably v1.3.2), or installing the Udev rules by hand as mentioned in the previous post. Sorry for the confusion.

In the future the Ubuntu’s PPA channel will be updated, so no workaround like that would be needed.

1 Like

Sorry, it took so long for me to respond!

Thank you, the workaround worked like a charm! I’m a happy camper!

1 Like