Nitrokey 3A NFC not working on Windows 11 PC suddenly

My Nitrokey 3A NFC just stopped working most of the time when I tried to use it as a key to certain log-ins. Windows doesn’t seem to recognize the device anymore. I updated the app, loaded new firmware. It says 100% and when I click on my key, I get an error. I have no idea if I am supposed to share “error log files” publicly or not. I got a Yubikey before I heard of Nitrokey and now use Yubi as a backup and Nitro as my main key. However, I had to use the Yubi because Nitro was not working anymore, and the Yubi worked fine on 3 separate occasions where Nitro was never “recognized” no matter what USB port I put it into. I have no idea what’s going on or where to begin finding out.

Do you use any USB extension cable or USB hub? Can you check other USB ports?

The Nitrokey App 2 should be able to detect the key on Windows. Some webservices are setup to only allow specific certified FIDO 2 devices (e.g. Microsoft Azure with enforce attestation enabled)

For sharing possibly sensitive logfiles, I would recommend to contact the official support by email (support)at nitrokey com. Also as you might have some hardware defect. The Nitrokey team will walk you through this to identify whether your key works. Ideally, you should have your order number ready.

I tried directly into a USB 3.0 HUB with 4 ports, checking each port, and directly into every single USB slot on my PC, with no extensions or adaptors. The PC makes the USB sound when something is plugged in, but nothing happens when plugged directly into the PC. The Key shows up if I use a 4-port USB HUB, but it simply doesn’t work. I have the log file when I plug into the USB 4-Port, but clearly, I don’t have a log file for when I plug it into the PC directly because it doesn’t even recognize it in the first place to create a log report. I think you are right, though. I may need to contact Nitrokey themselves. I have my order number ready, and I noticed it is required when making support requests. Thanks a bunch. By the way, I haven’t even had the chance to do anything fancy beyond FIDO2. So, I don’t think I did something “weird” to it. Know what I mean. LOL.

Similar to My NK 3A is dead, Nitrokey support is useless, what to do next? and other reports on the forum?

Yes, similar to others. Only difference I seem to have is my 3A NFC seems to work with some accounts that have already been set up in the past. Like my Gmail, for example. One of my gmail accounts was reset using my key that was set up before. However, it doesn’t recognize for others that were set up before. Mine may be a glitch of some kind compared to an outright failure, as others seem to be experiencing. I do know from reading some folks posts that a batch of keys were defective with the metal casing, and they are replacing those. I just don’t know if each case with similar issues is from that batch. Mine, for example, I have had mine since 23/05/12. I contacted support to see if this was part of this “bad batch,” but I have not heard anything yet. I also have read that they take some time to respond. Is it just me, or has this been out long enough not to have these sorts of issues, quantity, and extreme delays in support? Am I being unreasonable? From my research, this has not been a “crowdfunded/new concept” for a long while now. It is a tad frustrating they wouldn’t have better infrastructure by now. To be super clear, I really like this key “on paper” and want these folks to succeed. In real life, it is difficult to honestly say this is on par with other security keys, and I have not been able to recommend it to others in good faith, yet. Especially when most of the population are NOT enthusiasts and/or “tech savvy” people.

1 Like

Key works fine for everything except connecting to the nitro app. As before, I am still unsure if it is “ME” or the key, yet. However, I am able to use the key on new accounts, update old accounts, and log in fine with it. My other “issue” was my “Bitwarden” extension was trying to “take over” my log in priority. I had to disable it. Then my key worked fine. That was a “Bitwarden” update I was unaware of.

1 Like

Did you try using the key on any other OS like Linux ?
So you are saying all other problems are no longer their and it works fine just like your yubikey does ?

Yeah if you have a bitwarden extension it does prompt for passkeys first , but it also has a button on the pop-up windows to chose a hardware security key instead.

Yes, key works fine now, as my Yubi does. My Bitwarden was not showing the “options” to select previously, and now it does. So now I am able to choose the key fine, as I was not able to before. That was the entire problem.

1 Like