Re-install QubesOs on NitroPad x230 *!can`t access tty....!*(A-Shell)

Hello together

Goal: Re-install QubesOs on NitroPad x230.
I followed all the instructions I found, but nothing helped.

Then I tried to update the heads firmware of the NitroPad.
I think I made a serious mistake.

As I have now reached the limit of my knowledge, I URGENTLY ask for HELP.

Every time I switch on my NitroPad it says:

I do not know what to do. Can anyone help me?

Thanks in advance.


what step in the instructions or at what point it failed? What you have there is the recovery shell, before that you should see a heads menu there you can choose “options” and then Boot Option - USB Boot. This way you should be able to reinstall Qubes

1 Like

Assume they got help elsewhere given the number of days since the post. But what seems to have happened here is that they have flashed the wrong Heads rom, seemingly the x230-flash rom which just provides a very minimal version of Heads to enable a flash of the full heads rom. You can see in the screenshot where it gives instructions to flash from a flash drive. What you are meant to do here is have the full working rom on an external USB (saved as x230.rom) and then run those two commands to flash the full rom. The list of roms in that link on the Nitrokey manual page (Firmware-Update — Nitrokey Documentation) includes both the flash rom and the correct full rom (hotp-verification). Presumably they downloaded the flash one by mistake.

1 Like

Thank you for your answer.
I have found a solution.
Problems still exist.
Especially with the Qubes OS installation.

Thank you for your commitment

Hai rjbiii

You’ve got it.
I noticed that at some point.
I have solved this problem.
Other problems persist.
Especially with the Qubes OS installation.

Thank you for your commitment